Land 8.9: bien plus lent (mauvais) que Land 8.8.1 pour l'édition de traces

Kommentare

16 Kommentare

  • Avatar
    Thierry CHARLÈS

    Bonjour,

    NON, mais je n'utilise  pas LAND de cette manière.

    Cependant j'ai fais un essais j'ai construit a l'instant une trace  en enchaînant  des clics très rapides le constat est différent du tien, sur n clics rapides dans un intervalle très courts il ne prend pas les clics rapproches, il fait du 1/n .  exemple sur  10 clics il va prendre le 1, le 4, le 7 ... Ont voit bien ce temps de latence avec le curseur qui pédale et il faut attendre la fin de ce "pédalage" pour la prise en compte d'un nouveau clic

    Le bug que j'ai vu c'est que la construction se faisait par ajout de point a partir la fin (ajout en queue) , un moment ca  a basculer sur ajout de point devant le début (ajout en tête) mais jamais de croisement comme ceux que tu montre. 

    Pour le moment je suis satisfait de LAND 8.9, mais je ne trace plus avec Land, je l'utilise pour enrichir des traces construites ailleurs

    Cordialement

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Merci Thierry

    Cela conforte mon expérience qu'il est difficile d'utiliser land 8.9 pour construire ses traces, à cause de cette forte latence d'enregistrement d'un nouveau point sur une trace.

    S'il saute des points ou les enregistre au mauvais endroits, le résultat est le même : la trace n'est pas utilisable à cause de points aberrants (parfois il enregistre des points où je n'ai jamais cliqué mais probablement à l'endroit où était la souris en déplacement lors du fin du temps de latence, donc totalement imprévisible). Il faut alors corrigé les points un par un.
    Seul moyen, attendre suffisamment entre chaque point...

    Bref je suis revenu à 8.8.1 qui était toujours installé et fonctionne plutôt bien. Je ne peux que remercier la personne qui m'avait recommandé sur ce forum de toujours garder l'ancienne version avant d'avoir tester à fond les nlles versions de Land, souvent buggés au départ.

    En parallèle, j'ai signalé le problème à Twonav en espérant que le problème soit réglé sur une prochaine mouture. Si j'ai une réponse, je vous dirai.

    Bonne soirée

     

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Bernard Perrot

    Bonjour,

    Non, je n'ai absolument pas constaté de problème de ce point de vue.

    D'une façon générale, malgré le fait que Land présente toujours des bugs d'une version à l'autre, je trouve cette version 8.9 au moins aussi fonctionnelle et utilisable que la précédente.

    Concernant le retard en tracé, il peut être bénéfique de ne pas utiliser la fonction de centrage automatique en mode tracé, c'est une fonctionnalité très pénalisante puisqu'il faut recalculer l'affichage de la carte à chaque nouveau point.

    Bien vérifier aussi que le paramétrage est strictement identique entre votre installation 8.8 et 8.9, en particulier l'usage ou pas de OpenGL en mode 2D.

    Cordialement,

    PS : je suis sur Mac.

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Bonjour

    Moi aussi je n'utilise pas la fonction recentrage auto (j'avais effectivement constaté dans le passé la même chose). Donc le soucis ne vient pas de là. Pour ma part c'est W10 ; je ne sais pas s'il y a une différence dans l'adressage de la mémoire et du CPU par le soft par rapport au Mac, c'est possible effectivement.

    Je continue donc d'utiliser Land 8.8.1 pour modifier et créer des traces (Land est mon seul éditeur de traces pour mes sorties) car Land 8.9 est rédhibitoire en lenteur entre chaque point.

    Si on va trop vite, il faut revenir en arrière et supprimer les points aberrants créés par le soft parfois à des endroits où l'on a jamais cliqué, probablement des points captés par erreur durant le survol de la souris en déplacement. Il faudrait que je puisse faire une "vidéo copie d'écran" pour montrer le comportement buggé mais je ne sais pas comment faire cela facilement (sauf à filmer avec un smartphone ?).

    J'ai tout de même laissé 8.9 installée en attendant une nlle version corrigée (j'ai signalé le pb aux concepteurs). 

    Pour le moment rester sur 8.8.1 ne me pose pas de pb.

    Bonne journée à tous

     

     

    0
    Aktionen für Kommentare Permalink
  • Bonjour,

    Il faudrait que je puisse faire une "vidéo copie d'écran"

    Sous W10, il y a un "truc" avec XBOX, j'ai lu qu'il faudrait installer "une Barre jeu". Une association de touches démarrerait une capture vidéo de l'écran.

    Cela sert aux joueurs pour "immortaliser" leurs exploits...

    Faudrait chercher dans l'aide XBOX ou les sites de jeux pour plus d'infos.

    Cordialement

    Laurent

    0
    Aktionen für Kommentare Permalink
  • Avatar
    www.twolandnaviste .fr No official forum

    Suite:

    W10

    Démarrer, Paramètres, Jeux, Barre de jeux

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Bernard Perrot

    Bonsoir,

    "Je ne sais pas s'il y a une différence dans l'adressage de la mémoire et du CPU par le soft par rapport au Mac"

    Si, ce sont des OS différents (et même très différents du point de vue kernel), donc, la gestion de la mémoire est différente.

    Ceci dit, avoir un retard dans la prise en compte des points, c'est une chose. Mais si pour vous, ils ne sont même plus dans l'ordre, c'est vraiment un problème grave. Maintenant, est-ce un bug Land, ou une nième bizarrerie entre Land et W10... ?

    C'est "amusant", pendant très longtemps, c'est la version Mac qui fonctionnait moins bien que la version Windows, mais il semble que plus récement, ce soit devenu le contraire ! Et à mon avis, pas parce que Twonav a fondamentalement amélioré la version Mac, mais plutôt parce que W10 et ses mises à jour incontrôlables et de plus en plus buguées devient de moins en moins fiable.

    Pour moi, sur PC/Win, mieux est de s'en tenir pragmatiquement à W7...

    Cordialement,

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Thierry CHARLÈS

    Bonjour,

    Pour mettre en évidence ce phénomène il faut enchaîner des clics très rapides. Il est fort probable que cela ne gêne que peu de personnes.

    Ce que j'ai constater, il faut enchaîner des clics ultra rapprochés. Apres un clic d'ajout de point, le "sablier" s'active pour signifier que l'algorithme "pédale", si l'utilisateur attend que le sablier s'efface le fonctionnement est correct. Si l'utilisateur clic une ou plusieurs fois pendant que le sablier "pédale" ont constate le phénomène relaté..

    Vous pouvez essayer chez vous

    CDLT

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Bonsoir Thierry

    C'est exactement ça.

    Mais pour moi c'est rédhibitoire pour cette version de Land, car l'attente avec le sablier peut durer plus d'une demi-seconde (parfois proche de la seconde ; je n'ai pas mesuré, juste le ressenti). Donc un ou deux clics par secondes est ma façon de faire des traces (je les souhaite précises donc je les enregistre avec cartes en HD avec des points qui "collent" au chemin. S'il faut attendre 0.5 sec. ou plus à chaque fois et mater le sablier avant de faire le clic suivant...).

    Avec Land 8.8.1 ce problème n'existe pas.

    Quelque chose a donc était changé qui ralentit fortement la création de traces. J'avais indiqué ma suspicion pour 2 des nlles fonctionnalités vantées par CompeGPS : "Enregistrement automatique des traces en temps réel" et/ou "Nouvelles fonctions ‘Annuler’ et ‘Rétablir’ dans la barre de boutons", car ces 2 fonctionnalités rajoutent forcément du traitement d'info et enregistrement à chaque nouveau clic de trace.

    Perso je trouve frustrant d'avoir acheté un soft mis à jour avec des versions qui créent des nouveaux problèmes non présents auparavant. On avait déjà eu le même type de situation entre Land 8.5 et 8.6 ; rappel de la discussionhttps://support.twonav.com/hc/fr/community/posts/360041628331-land-8-6

    Ceci dit, je trouve quand même que Land est vraiment bien, mais il faudrait que les concepteurs passent plus de temps à tester en détails les nlles versions avant de les recommander à l'installation. Ou les mettre en béta test auprès de ceux qui sont d'accord pour débugger, avant de les pousser à tous le monde.

    Bonne soirée à tous

    fred

    0
    Aktionen für Kommentare Permalink
  • Bonsoir,

    CompeGPS dit, pour Land 8.9:

    Les boutons "Annuler" et "Rétablir" ont été ajoutés par défaut à la barre de boutons,

    Pour moi, ce sont les boutons qui ont été ajoutés par défaut, pas leur fonction.

    Avec "mes" Land successifs, je personnalise les outils et j'y ajoute les boutons Annuler et Rétablir.

    Leur fonction n'a rien de nouveau mais maintenant, si je passais à Land 8.9, je n'aurais pas à personnaliser ma barre d'outils. Les boutons y seraient, par défaut.

    Il y a peut-être un problème de traduction car ceux que j'ajoute s'appellent Défaire et Refaire. Land 7.6.1 a ces boutons.

    Regardez dans les icônes que je pouvez rajouter à Land 8.8.1, vous y trouverez surement ces 2 boutons. Ils sont sur Land 8.8.0.

    Cordialement

    Laurent

    0
    Aktionen für Kommentare Permalink
  • Avatar
    William Dosik

    J'avais eu ce problème de lenteur dans une version précédente. La solution qui m'avait été donnée :

    Décocher la case : utiliser open GL en 2D dans général

    dans Land >>> FICHIER >>> Option >> vues >> général

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Merci William.

    Malheureusement cela ne change rien.

    Dans mon cas, Open GL était activé mais aussi pour v8.8.1 pour lequel il n'y a aucun soucis. J'ai néanmoins essayé de tester en l'enlevant sur v8.9 mais toujours le même problème rédhibitoire de latence.

    Cordialement

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Bonjour

    Grâce à l'astuce de Laurent (Xbox sous Windows), j'ai pu enregistrer une courte du vidéo de ce qui se passe lors de la création d'une trace avec Land 8.9. 

    J'ai tracé quelques points en cercle, à une vitesse pas du tout folle (en fait plus lente que je souhaite), et constate que les points sont enregistrés dans le désordre, certains des points du début étant rajoutés au milieu ou même à la fin alors que la souris est immobile en fin de trajet.

    La vidéo est ici : http://www.mediafire.com/folder/qum4i8z3mras5/TUTO_IGNmap_%2B_Land
    2ème fichier : "Video du probleme Land 8.9 - Creation de trace.mp4" (environ 20Mb)

    Le même test sur Land 8.8.1 se fait sans problème, et même à une vitesse bien plus rapide d'enregistrement des points.

    Je vais partager cette video aussi avec Twonav à qui j'ai déjà signalé le pb.

    Bonne Pentecôte !

     

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Depuis le post ci-dessous, je continue d'utiliser v8.8.1 puisque que v8.9 ne fonctionne pas correctement (comme prouvé dans la vidéo envoyée au fabricant et partagée ci-dessus).

    Entre temps, Twonav a sorti la v8.9.1, mais... aucune indication si le problème est résolu ou pas !
    https://support.twonav.com/hc/fr/articles/360012815839-Land-8-9

    Du coup, je ne sais pas si cela vaut le cop d'installer cette nlle mouture qui a potentiellement le même défaut majeur que v8.9... ou pas, mais comment savoir. En attendant je suis toujours avec v8.8.1 mais j'ai écrit à Twonav pour savoir.

    A suivre

    Cordialement

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    Bonjour à tous,

    Je viens d'installer Land v8.9.1 pour essayer quand même. Et malheureusement, toujours le même énorme bug pour la création de traces, le problème étant l'extrême lenteur de la prise en compte des clics de souris pour les points de traces.

    Les clics sont enregistrés dans le désordre par Land 8.9.1 si on les fait rapidement, du coup la trace est totalement erratique et ne correspond pas du tout à la suite de clics que l'on a fait.

    J'ai refait une vidéo de capture d'écran. Avec la souris, je dessine une succession de points en spirale, qui devrait donc donner une trace en spirale. Las, rien de tout ça au résultat.
    Le lien de la vidéo est ici : http://www.mediafire.com/file/nu55eutmj9r3iro/file

     

    Pour comparer, si je fait la même chose avec Land v8.8.1, il n'y a aucun soucis. Et pourtant je suis allé encore bien plus vite dans mes clics. Voir la vidéo : http://www.mediafire.com/file/37uizvfdz6lzmpk/file

    La version 8.9.1 reste donc impossible à utiliser pour faire des traces. Heureusement j'ai gardé la v8.8.1

    J'en informe Twonav en parallèle.

    Cordialement

     

     

     

    0
    Aktionen für Kommentare Permalink
  • Avatar
    FREDERIC ALONSO

    A peine testé, Land m'a proposé la mise à jour v8.9.2 que j'ai installé. Mais c'est exactement le même problème que dans les vidéos du 8.9 et 8.9.1 : impossible de faire une trace avec une suite de clics pour chaque point.

    Cordialement

    0
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.