Message d'erreur LAND après mise à jour de 8.9.5 vers 8.9.6 au démarrage

Commentaires

48 commentaires

  • Avatar
    Daniel Fumagalli

    Oui les cartes fonctionne normalement. Pourquoi tu me demande cela ? Si c'est sur le fait d'avoir essayé de désactiver OpenGL 2D et le fait que la ou les cartes soient flou ? (en fait sur la ou les carte IGN c'est le nom d'un lieu qui se dédouble légèrement et qui donne se flou. Avec Land 8.9.2 pas de PB .

    CDLT

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

     Bonsoir

    "Je tiens à préciser que le chemin d'accès aux cartes à toujours été c:/document/compegps/map et y est toujours, dans les préférences da land le chemin d'accès est le même : c:/document/compegps/map toutes mes cartes sont dans ce répertoire et nul part ailleurs."

    Ok OUI, de ce que j'ai constaté c'est que ce que voit dans préférence n'est pas forcement ce qui est utilisé. Tu peux faire un test tu change ces chemins et tu redémarre Land puis tu va voir ce qu'il y a dans préférence : Tes modifications ou ce qu'il y avait avant? 

    Je site ( La modification des dossiers via le menu de Land (Fichier/Préférences/dossiers) semble ne plus fonctionner.) Pour moi c'est bon !! Je peux également changer de dossier ça fonctionne)

    Par contre en désactivant Open GL 2D tout fonctionne mais la cartes sont un peu flou pas top !!  OUI, j'utilise 8.9.6 avec OPEN GL Coché

    je vais finir par croire, que comme pour Windows, chaque mise à jour apportent sont lot de Bug.

    J'ai l'impression que land ne trouve pas les carte lors du démarrage ? C'est compliqué j'ai réussi a stabiliser tout ça en corrigeant manuellement les gps.ini et gps.default

    Je ne vois pas ou je pourrais en avoir autre part, j'ai fouillé partout dans les disques.

    Si quelqu'un à une idée je suis preneur. J'ai fait également remonté le PB au SAV Twonav admin.

    J'utilise avec moins de blocage land 8.9.6 après avoir mis en cohérence les fichiers gps.ini et gps.default avec un éditeur de texte. Il y a toujours des bugs comme le drawing error quand le zoom part en butée, d'autre bugs mais cote accès aux cartes , fichiers et la synchro CLOUD fonctionne.

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Daniel Fumagalli

    Bonsoir,

    Mise à part ce message d'erreur "drawing error detected please reoort the problem at support.twonav.com 56." je n'ai pas de PB particulier avec Land ,mais ce message est pénible !!!. Du coup j'ai de nouveau coché OpenGL 2D. Tu ne sais pas si les développeurs sont sur ce problème ? Je crois que le PB vient d'un bug logiciel . Je cite : Il y a toujours des bugs comme le drawing error quand le zoom part en butée" 

    Moi le message d'erreur c'est au lancement de land . J'ai l'impression qu'il ne trouve pas les cartes ?

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Suite

    Land 8.9.6 sans avoir coché Open GL la carte est floue quand on zoom, et sans Zoom c'est baveux pas net, sur les versions précédentes OpenGL coche ou pas je n'ai jamais vu de différence..

    Concernant le message Drawings error, ce que j'ai constaté lorsqu'il a monté le bug est systématique même après un redémarrage de Land et du PC. Pour le faire disparaitre je suis passé en 8.9.2 et au démarrage ma carte était en zoom infini.  Land 8.9.2 a automatiquement corrige le zoom. Du coup je suis repassé en 8.9.6 pour constater si le bug était toujours là.. Et bien non il a disparut. Donc c'était lié au ZOOM et dans mon cas ca s'est produit après création d'un WPT.

    Il y a deux fichiers GPS.ini et un fichier GPS.default selon le cas du boot de land il charge l'un de ces fichiers, et sauve le contenu dans les autres gps.ini. 

    Du coup si tu as un chemin erroné dans l'un des GPS.INI ou .default il n'ira pas chercher les cartes au bon endroit (par exemple) tout en présentant un chemin correct dans fichier/préférences.. C'est ce que j'en ai conclut. 

    Dans mon cas comme j'avais déplacé le répertoire de travail ailleurs que dans data, j'ai vu que mes changements n'était pas pris en compte. Ce qui m'a incité a fouiller de  de coté.

    Bref depuis que j'ai fait le ménage dans ces fichiers, je peux utiliser 8.9.6 sans trop de mauvaises surprises.

    J'ai reporté tout cela au SAV, qui ne m'a pas contredit. Ils attendent eux aussi une version non buggée avec impatience.

    Compte tenu de ce qui s'est produit sur cette version il y a une grosse remise en cause processus, qualité et probablement de personnes a faire en interne.

    CDLT

     

     

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Suite

    Moi le message d'erreur c'est au lancement de land . J'ai l'impression qu'il ne trouve pas les cartes ?

    OUI OUI .. Tu a du fermé Land avec cette erreur, tu crois qu'il ne trouve pas la carte que tu ne voit pas, elle est ouverte avec un ZOOM INFINI. 

    Ca correspond exactement a ce que j'ai constaté

    Pour faire disparaitre je suis repassé  en 8.9.2 dans cette version Land a remis le ZOOM correct donc la carte devient visible. Retour en 8.9.6 et c'est OK

    Essaie de revenir a un ZOOM correct

    CDLT.

    0
    Actions pour les commentaires Permalien
  • Avatar
    Daniel Fumagalli

    Ils sont ou ces deux fichiers gps.ini et gps.default ?

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS
    • :/programmes/TwoNavLand/gps.default
    • "Mon chemin"/CompeGPS/AppData/gps.ini
    • c:/programdata/TwoNavLand/gps.ini

    Drawing error c'est le problème de zoom infini je pense, comme c'est dilate au max on croit qu'il n'y a pas de carte mais non elle est en zoom infini!

    gps.ini et default faut bien vérifier la cohérence, dans mon cas le passage en 8.9.6 a mis le bazard dans ces fichiers (exemple il y avait deux chemins vers le data pour le CLOUD la synchro cloud était bloquée, mes cartes ca pointait pas au bon endroit).

    CDLT

    0
    Actions pour les commentaires Permalien
  • Bonsoir,

    Zoom infini.... Je ne comprends trop ce problème mais ce n'est pas grave.

    Par contre, dans l'Arbre, Clic droit sur la carte et Zoom ici ne vous remet une échelle "carte recentrée en plein écran", dirais-je ?

    Cordialement

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Daniel : Quand le  bug est présent ce que tu peux tenter c'est d'ouvrir le fichier c:/programmdata/twonavLand/default.cjt puis de voir s'il n'y a pas une valeur nulle (autre que z = 0) ou excessive dans les données du champ <rec>

    <view mode3D="0" Xangle="0" Zangle="0">
    <rect>
    <p1 x="8.57551765" y="41.81543350"/>
    <p2 x="9.01850510" y="42.03165054"/>
    </rect>
    <eye x="8.79661751" y="41.92377853" z="8463.07812500"/>
    <center x="8.79661751" y="41.92377853" z="0"/>
    </view>

    Ces valeurs sont en gros pour la corse.

    CDLT

    0
    Actions pour les commentaires Permalien
  • Avatar
    Daniel Fumagalli

    Charles,

    J'ai trois dossiers dans c:/programmdata/twonavLand/default.cjt et toi ?

    default.cjt 

    default.cjtold

    default.cjtold_Err

    Cdlt

     

     

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Bonjour,

    Voila ce que j'ai .

    Les dates des fichiers sont  importantes vu que c'est un fichier mis a jour chaque fois "ou presque" que tu interagit avec l'écran. Le Zoom c'est probablement la valeur du z de eye.

    Pour un zoom de la carte de 0m /pixel : z = 3.8; pour un zoom de 30 m par pixel sa valeur est proche de 9000.

    Tu a toujours le message d'erreur quand tu ouvre Land?

    Cordialement

     

    0
    Actions pour les commentaires Permalien
  • Avatar
    Daniel Fumagalli

    Bonjour Thierry,

    Tout d'abord mille excuses d'avoir confondu ton nom de famille avec ton prénom, j'en suis encore désolé.

    Voila ce que j'ai. le PB est le même.

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Bonjour,

    Pas grave.

    Ok si tu ouvre le fichier default.cjt avec notepad par exemple quelle est la valeur du z de eye ?

    Sinon pour que le bug s'en ailles c'est simple retour en 8.9.2 puis 8.9.6 ..et le bug s'en va. 

    Ce qui m'incite a penser qu'il y a une valeur de bloquée dans un fichier de config.

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Daniel Fumagalli

    </maps>
    <view mode3D="0" Xangle="0" Zangle="0">
    <rect>
    <p1 x="8.77225876" y="42.54973602"/>
    <p2 x="8.83094978" y="42.58656311"/>
    </rect>
    <eye x="8.80158424" y="42.56820679" z="2896.69848633"/>
    <center x="8.80158424" y="42.56820679" z="0"/>
    </view>
    </XCJT>

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Daniel Fumagalli

    Effectivement si cela ne va pas, c'est simple retour en 8.9.2 puis 8.9.6 et on verra.

    Cdlt

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Voila fais ça .. J'en ai parler quand ca m'est arrivé au SAV. 

     

     

     

    0
    Actions pour les commentaires Permalien
  • Bonjour,

    Et prendre un default.cjt du GPS pour le mettre dans Land, ce serait idiot ?

    (Eventuellement en ayant fermé cartes, TRK et WPTs dans le GPS)

    A comparer, ils semblent très proches....

    Cordialement

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Bonjour,

    En complément de ces manips afin de comprendre et de trouver un palliatif à ce bug lorsqu'il se reproduira, j'ai un peu jouer a ouvrir différentes cartes ce matin. 

    Constat elles s'ouvrent avec Land 8.9.6 a des échelles différentes et si on observe dans TwoNav les fichiers qui sont mis à jour il y a un indexmap.dat, il est donc concevable d'imaginer que le bug puisse se situer dans ce fichier .

    J'ai donc sauvegardé dans un "dossier à part", ce fichier dans un état sans bug. Le jour ou le bug se reproduira je tenterai de le substituer à celui qui sera actif.

    Dans le bloc des fichiers mis de coté pour débloquer Land 8.9.6 lorsqu'il sera bloqué avec ce message d'erreur j'ai placé 

     

    A suivre

    Cordialement 

    0
    Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.