Attention : Land v9.1.2 et 9.1.3 hautement instables

Commentaires

10 commentaires

  • Avatar
    Thierry CHARLÈS

    Bonsoir,

    Pour revenir en arrière c'est plus simple que la solution que tu avance. Il faut juste récupérer un setup land xxx.exe.

    Par contre ce qui est important pour faire disparaître les défaut c'est de procéder de cette manière:

    - Tu commence par faire une copie des dossier data et map qui sont dans le x:/documents/compeGps/

    Ceci afin de repartir avec tes données.

    Ensuite:

    • faire un  "uninstall de  land", important pour effacer correctement
    • delete "x:/documents/compeGps/..." (Bien vérifier que ce dossier disparaît totalement)
    • delete "C:/programm/TwoNav
    • delete "c:/programm (x86) /TwoNav
    • delete "c:/programdata / Twonav (vérifier qu'il n' y a pas un /compeGps qui date de Land 7 et l'effacer)

    Arrêt du PC , puis Marche 

    A ce stade toute trace de Land est en principe effacée

    Réinstaller une version antérieure (la plus stable est 8.9.2)

    Apres l'installation il demande le code d'enregistrement pour les versions antérieures a land 9, le code est sur ton compte rubrique ../mes produits/mes logiciels

    Il se peut qu'il demande ce code aux deux premiers démarrage,  bien saisir celui qui correspond a la bonne version (attention le plus haut sur la page /mes produits/mes logiciels/.. n'est pas forcement le bon.

    Tu copie les dossiers data et map que tu avait sauvegardés dans c:/document/compeGps/ qui a été créer suite à l'installation. Cette copie va écraser les deux dossiers contenant les fichiers de démonstration, et tu retrouve tes données et cartes intactes.  

    Je suis revenu trois fois de Land 9 a Land 8.9.2, je me posais la question d'essayer Land 9.1.2 tu m'a donné le bon argument pour éviter.

    Ce qu'il faut retenir, jusqu'à 8.9.5 Land est une version 32 bits a partir de 8.9.6 c'est une version 64 bits. Ce que j'ai pu constater entre autre ce sont des erreurs dans les différents fichiers de configuration ce qui provoque un fonctionnement bizarre. Les version 32 bits s'installent dans c:/programm(x86) et les versions 64 Bits dans c:/programm/  du coup quand on migre de 32 vers 64 bits et inversement sans désinstaller ni supprimer les dossier l'installation de Land, l'installation récupère et duplique les fichiers de configuration existant, qui se multiplient au final  il y en a partout ensuite quand Land se Plante, il boot sur de fichier de conf erronés, ou ca va créer des erreurs, ca une des config est biaisée . 

    J'ai maintenant une version stable 8.9.2 qui fonctionne correctement.

    Vu les évolutions Land 9 cette version n'a pas grand intérêt.

    CDLT

     

     

     

    0
    Actions pour les commentaires Permalien
  • Avatar
    FREDERIC ALONSO

    Bonsoir

    Merci pour ta longue réponse.

    Concernant le fichier de config à récupérer et à coller, je faisais cela dans le passé. J'installais à chaque fois la nlle version dans un répertoire différent, ainsi j'avais les 2 Lands installés en même temps et qui fonctionnaient. Je copié/collé les fichiers de config manuellement et je ne supprimer l'ancienne version que quand j'étais convaincu de la stabilité de la nouvelle. A au bout d'un moment, cela a commencé à créer des problème, ce qui est normal : si les menus paramétrables changent, récupérer les settings de l'ancienne version et les plaquer de force sur la nlle, c'est pas toujours une bonne idée...

    Maintenant je procéde différemment : j'installe la nlle version sur l'ancienne (c'est ce qui se passe quand on fait la mise à jour automatique proposé par Land quand il découvre une nlle version dispo, donc c'est "normalement" tout à fait logique de procéder ainsi). S'il y a un problème, je colle une image de mon disque C:Windows (sauvegarde TrueImage) et je reviens exactement au point d'avant.

    En général, tous les menus réglables sont conservés et ça marchait nickel, par exemple entre 9.0 et 9.1 Mais avec la version 9.1.2, patatras, totalement instable. J'ai essayé de réinstaller les anciennes versions (9.0) mais cela ne marche toujours pas. Cela veut dire que l'installation de la version 9.1.2 sur la précédente 9.1 a endommagé des fichiers et c'est irréversible.

    Avant de décider de restauré C:, j'ai quand même essayer quelque chose : j'ai totalement désinstaller Land et j'ai fait une installation propre de Land 9.1.2 (la dernière). Miracle, ça marche normalement.

    Par contre, il m'a fallut 30-40 min pour remettre tous les réglages des menus et des barres d'outils comme je le souhaite. Heureusement, je me suis fait un PDF avec copie d'écran de chaque page du menu "préférences" (et il y en a !...) afin d'aller plus vite.

    Conclusion

    • Il ne faut pas faire la mise à jour du soft, ce qui est pourtant la voie la plus logique car permet de conserver ses paramétrages.
    • Land 9.1.2 semble marcher en tant que nlle installation, après avoir désinstallé l'ancienne version.
    • Il faut refaire tous les paramétrages (ou tenter l'option copié/collé rappelée par Thierry).

    Bon allez, je vous laisse car j'ai mes traces pour mes sorties VTT de cet été à préparer maintenant que tout remarche avec 9.1.2.

    Cordialement

     

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Bonjour,

    Je ne sais pas ce que tu utilise comme type de circuit pour faire du VTT (Trace, RoadBook ou route type rte) mais méfiance la nouvelle version TwoNav 5.1 modifie significativement le guidage (a priori, ca reste a vérifié)  le suivi d'une Route.rte n'est plus possible.

    Une modification de cette nature au seuil de l'été c'est beta, je pense que j'ai tout ce que j'ai préparé a rependre. Je verrai ça Mercredi matin, ce matin c'était Trail donc avec Suunto!

    CDLT

    0
    Actions pour les commentaires Permalien
  • Avatar
    FREDERIC ALONSO

    Salut

    D'abord concernant le logiciel, tout semble fonctionner maintenant en v9.1.2. Au lieu de faire des mises à jour, il faut faire une installation propre après désinstallation. Un peu fastidieux mais bon.

    Concernant mes traces, j'utilise exclusivement des fichiers .trk depuis le début (quand je télécharge des .gpx, je les transforme immédiatement en .trk). J'ai bien sûr un GPS Twonav. Je n'ai jamais bien compris ce qu'était une "route" dans l'esprit Twonav... donc jamais utilisé, mais en fait les traces trk me conviennent très bien donc je ne cherchent pas plus loin.

    Ciao

    0
    Actions pour les commentaires Permalien
  • Avatar
    FREDERIC ALONSO

    Finalement je reviens sur mon dernier message : Land 9.1.2 est beaucoup moins stable que Land 9.0. Parfois il se fige pensant plusieurs minutes sans raison apparente. Au début je forcer l'arrêt, puis j'ai essayé d'attendre et au bout de qques minutes il redevient normal. Instable quoi... Et pourtant je l'ai installé seul et proprement à partir de zéro sur un ordinateur récent et très puissant.

    Je vois que la version 9.1.3 vient de sortir sans qu'on puisse savoir ce qu'il y a dans cette nouvelle mouture ! Corrections des bugs de la version 9.1.2 ? Qui peut dire ?

    Je vais faire une image disque et tester (cela ne peut pas être pire, non ?), quitte à remettre l'image C: s'il le faut revenir en arrière

    0
    Actions pour les commentaires Permalien
  • Avatar
    FREDERIC ALONSO

    Je viens d'installer Land 9.1.3 mais malheureusement même problème. Visible sur copie d'écran ci-dessous, le soft se fige et tout devient grisé et plus rien ne se passe. Pendant de LONGUES minutes.

    Je me demande si je ne vais pas revenir à une ancienne version, Land 8 qui marchait mieux (plus stable de mémoire).

    Mais COMMENT SE FAIRE REMBOURSER L'ACHAT DE LA VERSION 9 avec laquelle je souffre depuis l'achat en février 2022 ???

    A noter quand même : j'ai énormément de cartes (plus de 80 000 cartes pour couvrir toute la France en détails). Quand j'enlève toutes les cartes du répertoire "cartes" et que j'ouvre le .imp à partir d'un autre répertoire, je n'ai plus le soft qui se fige. Donc il a un grand problème à gérer un très grand nombre de cartes. Mais... j'avais déjà les mêmes cartes avant et sans problème. Je pense donc qu'il y a une mauvaise gestion de la mémoire vive (lié version x64 ?) et pourtant j'ai bloqué le scan automatique des cartes (qui ne changent pas donc pas besoin de rescanner).

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Bonjour,

    J'ai installé Land 9.1.3 hier sur mon PC (Après avoir fait le ménage voir plus haut) et ça  s'est très bien passé, Land 9.1.3 fonctionne correctement. 

    Ce qui ne fût pas le cas avec les versions précédentes de Land 9, du coup j'étais en 8.9.2 mais là aussi il faut faire le ménage, sinon on traine des bugs..

    Enfin une version Land 9 qui fonctionne!

    CDLT 

    0
    Actions pour les commentaires Permalien
  • Avatar
    FREDERIC ALONSO

    En fait pas complètement !!

    Je viens de passer des heures avec Land 9.1.3 pour faire mes traces de cet été. Il fonctionne très bien MAIS seulement après avoir enlevé tout mon stock de cartes du répertoires "cartes". Dans ce cas j'ai pu faire mes traces nickel (mais pas mieux qu'avec Land 9.0 qui fonctionnait pareil très bien sans cartes dans le répertoire "cartes").

    Donc je dirais que ce soft continue d'avoir un très gros problème de gestion des cartes. Quand il y a beaucoup de carte dans le répertoire, il part en sucette sans arrêt, et pourtant les cartes ont déjà été toutes scannées une fois par le logiciel et ensuite j'ai mis le scan automatique sur "jamais". Malgré cela, il semble que le soft continue de faire quelque chose en background qui le bloque durant plusieurs minutes, plusieurs fois durant l'utilisation. Et je reconfirme que mon installation est totalement propre sans traces des versions précédentes (ce qui m'a valu de refaire toutes les personnalisations).

    Je pense que Twonav fait ses tests avec un petits nombre de cartes et les développeurs software ne voient pas le problème. Il faudrait mieux tester le soft avec beaucoup de cartes dans le répertoires "cartes" (maps) pour ENFIN régler ce problème de stabilité.

    Donc j'ai contourné le défaut en mettant mes cartes ailleurs que dans le répertoire et en utilisant un .imp qui pointe vers ce répertoire différent.
    Mais ce n'est pas satisfaisant car si je dois faire une recherche sur une zone, Land ne va trouver aucune carte pour cette zone (logique, puisque mes cartes ne sont pas dans son répertoire de référence).

     

    0
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Suite,

    Intéressant comme observation, moi je n'utilise plus Land de cette manière.

    Quel type de carte utilise tu?

    Mon profil d'utilisation concernant les cartes :

    - Comme j'ai observé depuis "un bon moment" qu'a chaque démarrage,  Land passe un temps "fou" à mettre a jour la liste des cartes et des traces (Routes, Wpt, etc..), même si on ne les utilisera pas dans la séance: Donc d'une utilité discutable. J'ai depuis longtemps séparé l'organisation des cartes sur plusieurs répertoires; dans le x:/CompeGps/data/map je n'ai qu'un minimum de cartes (celles autour de chez moi) les autres sont ailleurs .../Relief (Pour les CDEM), .../Xmap/ Pour les autres (Quasiement  30 répertoires un par zone géographique) . Et seul le data est listé dans "option" donc au démarrage le temps du scan est raccourcis, sans action complémentaire seule les "cartes locales" sont visibles. 

    Ensuite si la carte n'est pas dans ..../compeGps/data/map.., quand l'intérêt est "ailleurs"  il suffit de faire carte/ouvrir/ .. Comme de toute façon, le choix reste  enregistré au démarrage suivant cette carte sera chargée (idem pour les reliefs) : Donc pour les cartes utilisées "hors de la zone de confort" ce n'est pas une gêne vu qu'il ne faut "aller la chercher" qu'une foi. 

    - Je n'utilise plus les tuiles / dalles IGN achetées via land (Pas a jour et résolution discutable), mais j'utilise  le script qui permet d'avoir les IGN (Cartes/Plan/Ortos) gratuites de la France entière (Idem hors de France). Et ce script est léger donc il est dans .../data/map  avec les cartes locales (OSM) sans impact sur la durée du scan.

    - Idem pour la Carto OSM la 21 q2, dans le data et les "pastilles" a jour pour le GPS dans des répertoires distincts (ca facilite grandement la mise a jour et le suivi, un seul fichier a remplacer)

    - Comme avec Land 9 il y a Map plus. 

    De plus pour "préparer un itinéraire" vu la "fluidité" de fastTrack j'utilise QmapShack (qui fonctionne en gros comme expliqué ci dessus) qui permet avec un "Brouter' optimiser de "router" rapidement et efficacement, le "travail" de préparation je le fait sur Qmap avec des cartes on lines a jour.  Il ne reste pour le moment que la transformation de la trace en "*.rte" ou "Roadbook" dans Land. Pour rte je me suis fait une routine qui fait le boulot et roadbook c'est en cours et ca avance assez bien..

    Donc schématiquement, le besoin de charger des cartes qui ne sont pas dans le .../data/map/... se limite quasiement a deux cas (pour mon utilisation) :

    - Vérifier (s'assurer ) que la carte qui est dans le GPS va s'ouvrir correctement avant de partir (Hélas ca peut arriver, habitude prise avec les dalles type IGN de certains pays qui refusait de s'ouvrir après un certain temps, quand ca se produit au départ c'est ballot)

    - Création de cartes, pour le GPS

    CDLT

     

    1
    Actions pour les commentaires Permalien
  • Avatar
    Thierry CHARLÈS

    Complément,

    Par contre, ton constat est intéressant,  remonte le au SAV en ouvrant un ticket que la correction soit prise en compte.

    Cdlt

    0
    Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.